Re: [cf-dev] Can't Create Service Instance in Cloud Foundry

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: [cf-dev] Can't Create Service Instance in Cloud Foundry

James Bayer
looks like you already took what was going to be my advice and inquired on the maintainers of the services-contrib repo with an issue:

good luck

On Wed, May 6, 2015 at 8:20 AM, Matthew Landry <[hidden email]> wrote:


I'm trying to get the introduction to spring cloud
<https://spring.io/blog/2014/06/03/introducing-spring-cloud> app working
with an instance of Cloud Foundry that I'm running on my machine. I tried
to push the app and I get this message:

        Could not find service postgres-service to bind to hello-spring-cloud

That makes sense to me so I started tracking down the postgres service.
When I run `cf marketplace`, I get:

        service      plans     description
        mongodb      default   MongoDB NoSQL database
        postgresql   default   PostgreSQL database
        rabbitmq     default   RabbitMQ message queue
        redis        default   Redis key-value store

When I try to create a service instance of the postgresql service and I
get:

        $ cf create-service postgresql default postgresql-service
        Creating service instance postgresql-service in org xyz / space
development as admin...
        FAILED
        Server error, status code: 500, error code: 10001, message: Service
broker error: Not authorized

Here are the permissions for the space:

        Getting users in org xyz / space development as admin

        SPACE MANAGER
        admin

        SPACE DEVELOPER
        Admin

The cf service-access command doesn¹t yield anything interesting:

        $ cf service-access
        Getting service access as admin

Then it shows nothing on the terminal. So I tried to enable service access

        $ cf enable-service-access postgresql
        Enabling access to all plans of service postgresql for all orgs as
admin...
        All plans of the service are already accessible for all orgs
        OK

For the life of me, I can¹t figure out what¹s going on.  I posted a question to Stack Overflow <http://stackoverflow.com/questions/30034143/cant-create-service-instance-in-cloud-foundry> and was referred here after some debugging
attempts were fruitless.  Anybody got any ideas?


_______________________________________________
cf-dev mailing list
[hidden email]
https://lists.cloudfoundry.org/mailman/listinfo/cf-dev




--
Thank you,

James Bayer

_______________________________________________
cf-dev mailing list
[hidden email]
https://lists.cloudfoundry.org/mailman/listinfo/cf-dev