[cf-dev] Action Required: Deprecating the built-in garden aufs filesystem driver ("garden-shed")

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[cf-dev] Action Required: Deprecating the built-in garden aufs filesystem driver ("garden-shed")

Julz Friedman
Hi cf-developnauts!

I wanted to quickly remind y'all, and seek any remaining feedback, about our plans to deprecate the garden-shed filesystem driver in an upcoming garden release

We previously communicated about this here [0], the tl;dr is we have a new filesystem driver implementation, named grootfs, which has been running in production for a while now. At the start of the year we made this the default in garden [1], with an opt-out property to temporarily re-enable the old implementation, in case of problems. It's now coming up on 6 months later.

As far as we know - and this is where you come in! - all remaining bugs, issues and blockers requiring people to opt out of the new driver are resolved, and we are therefore planning to remove the deprecated garden-shed driver, and corresponding config option, in an upcoming garden release. 

ACTION REQUIRED: If you were opting-out of grootfs for any reason, please urgently try again and report any bugs or blockers to us (via GitHub issues, #garden slack, or Tracker) so we can fix them! As of right now we believe everyone is fine for us to delete garden-shed, and we plan to do that soon unless we hear otherwise!

Thanks!
Julz, on behalf of the gardenandgroot team,

_._,_._,_

Links:

You receive all messages sent to this group.

View/Reply Online (#8093) | [hidden email] | [hidden email] | Mute This Topic | New Topic

Your Subscription | [hidden email] | Unsubscribe [[hidden email]]

_._,_._,_